These pages are written by only Japanese.

Welcom to My Diary.com
最新の日記タイトル一覧カテゴリ別タイトル一覧トップへ戻る〜

こんばんわ♪ 現在は9月23日(月)4時5分。 静寂が闇を包む頃です。


hns - 日記自動生成システム - Version 2.19.5 (色々 Fixed)

先月 2008年10月 来月
01 02 03 04
05 06 07 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
Namazu for hns による簡易全文検索です。
詳細は 詳細指定/ヘルプをご参照下さい。
検索式:

2008年10月10日(金)

[swfed] mp3-dev branch 作成

replaceMP3Data のコードが書きかけで止まっているので、 他の修正をする度にコードをどかして commit してます。
そろそろ面倒になって来たので、mp3 対応の branch を切りました。
mkdir trunk
svn add trunk
svn commit
svn rename src trunk/src
svn rename doc trunk/doc
svn rename sample trunk/sample
svn commit
mkdir branches
svn add branches
svn commit
export SREPOS=https://svn.sourceforge.jp/svnroot/swfed
svn copy $SREPOS/trunk $SREPOS/branches/mp3-dev \
	-m "replaceMP3Data development"
svn update
mp3 対応は目処が立っていないのと、 他にやる事沢山あるので実質塩漬けですが…

2008年10月11日(土)

レインウェア購入

長時間の登山だと雨の時に安物の雨合羽でしのぐ訳にもいかないので、 登山用のレインウェアを購入しました。
オレンジ色のを見つけたので即購入。お店は↓ここ 買ったのは↓これ。 って、あれ… 赤? (゜Д゜;)
帰宅してから色が違うのに気づいたけど後の祭り。
写真だとモロに赤だけど実際には朱色に近い赤なので、 お店の照明の具合でオレンジに見えたのかもしれません。
お店では、オレンジ探してたんですよって店員さんに話しながら ウェアを手に取ったので、その時にソレ赤ですよって突っ込んで欲しかったな…
そんな訳で、さかいやスポーツでは 天然ボケに店員が突っ込んでくれないようなので、 買い物する時は要注意です。(´Д`;)
ま、赤も嫌いじゃないので別にいいや *1
*1: とか言いつつ愚痴ってるよね、この文章w

2008年10月12日(日)

大倉尾根往復

一人 *1大倉尾根 をつたって 塔ノ岳 まで登ってきました。
結構楽勝。最終的に 3リットル程水が余りましたし。

熊注意:

入り口:

序盤:

少しずつキツくなります。角度とか。

見晴茶屋:

満席だったので素通り。

坂坂坂:

ずーーーーーっと上り坂が続きます。もう笑うしかないです。

駒止茶屋:

風景:


見晴らし的にはアレですが、これはこれでオツなものです… (強がってみるテスト

堀山の家:

中盤:

ここからが地獄の始まり。(´∀`)

休憩:

後半:

更にペース・アップ

花立山荘:

終盤:

まだまだ続くよ。登り坂。

緑が一杯です。

あと一息:

頂上:


ワーッ。イイナガメダー (棒読み)

… 周りに何も見えません… ・゚・(ノД`)・゚・

帰り:

デジカメ手に持っての降りは結構きついです。
何度かアングルに納得いかなくて登り直したりしてますし。(´Д`;)

紅葉の兆候:

所々、葉が赤くなってます。

さて…:

頂上の眺め。2戦2敗… ○rz
次こそは…

*1: 仲間募集中。(;∇;)
でもバカ尾根に登りたがる人なんて、そういないだろうなぁ…


2008年10月14日(火)

[swfed] 画像フォーマットを気にせず image_id で画像入れ替えできるように

今までは、BitsLossless に対しては png 画像を。BitsJpeg に対しては jpeg 画像しか差し替えられなかったのですが、BitsJpeg に対して png 画像を。また、その逆でも差し替えが出来るようにしました。
あと、BitJpeg(1) にαチャネルを与えてもマスクが効きませんでしたが、 αチャネルがわたった場合に BitJpeg3 にタグを変換する処理も入れたので、 今後はαチャネルによるマスクが有効になります。
つまり、指定した image_id で入っている画像のフォーマットを意識せずに、 png でも jpeg でもαチャネルでも放り込めるようになったという事で… ついでに納得いってなかった箇所を大量に修正して commit。 動作確認が大変そうです。(´Д`;)

追記 (2009年10月7日追記):

「BitsLossless」で検索してこられたかた用のまとめ。

2008年10月15日(水)

[swfed] swfdump のソースコード公開

SWF ファイルの中身を解析するページを用意してますが、
http://awm.jp/~yoya/php/flash/swfdump/
移動しました。↓ これのソースコードを公開してという声は以前からあり、 また、使いたいけど仕事で使う SWF ファイルを awm.jp に POST する訳にも いかないので困ってるといった意見もあり、 ようやくですが、コードを公開しました。 (次回リリースからは tarball に含まれます) POST されたファイルを保存して id でアクセスする方式なので、 容量に余裕のあるディレクトリを define.php で指定して下さい。
何もしないと /tmp/swf-<id>.{swf} や /tmp/swf-<id>-<image_id>.(png|jpg) のファイルが出来ます。
% cd htdocs
% svn co http://svn.sourceforge.jp/svnroot/swfed/trunk/www
% mv www swfed
% cd swfed
% vi define.php
要望は随分前からあったので、対応が遅れたのはホントにごめんなさい。
汚いコードなのと、あと swfed の API で細かい所がなかなか fix 出来なかったので躊躇してました。

2008年10月18日(土)

CentOS で swfdec の install に挑戦 (失敗)

GLIB:

checking for GLIB... no
configure: error: glib-2.0, gobject-2.0 and gthread-2.0 >= 2.16 are required to build swfdec
glib2-devel や gtk2-devel を yum install してもダメ。
とりあえず、 GLIB=2.16 GLIB=2.0 に書き換えて他に問題ないか調べてみる。

PANGO:

checking for PANGO... no
configure: error: pangocairo >= 1.16 is required to build swfdec
CentOS だと 1.14 が入ってますね… これも外してみる… PANGO_VER=1.16 PANGO_VER=1.14

GTK SOUP:

checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.8.0 libsoup-2.4) were not met:

No package 'libsoup-2.4' found
libsoup-2.4 を libsoup-2.2 に書き換えてと… φ。。

ALSA:

checking for ALSA... configure: error: Package requirements (alsa >= 1.0) were not met:

No package 'alsa' found
yum install alsa-lib-devel

LIBOIL:

checking for LIBOIL... no
configure: error: liboil-0.3 >= 0.3.1 is required to build swfdec
yum install liboil-devel

CAIRO:

checking for CAIRO... no
configure: error: cairo and cairo-png = 1.6.0 is required to build swfdec
Package cairo-devel - 1.2.4-5.el5.i386 is already installed.
なので、 CAIRO_VER=1.6.0CAIRO_VER=1.2.4

GST:

checking for GST... no
configure: error: Couldn't find GStreamer 0.10.11 and gstreamer-pbutils 0.10.15.
yum install  gstreamer-devel
<略>
Installed: gstreamer-devel.i386 0:0.10.9-3.el5
Complete!
これもバージョンが古いか…
yum install gstreamer-plugins-base-devel
これでもダメなので諦め。
./configure --disable-gstreamer

これで、6 日分だよ〜。

タイトル一覧
カテゴリ分類
Database
JXTA
Java
XML
awm
bookmark
keyword
memo
news
research
Powered by hns-2.19.5, HyperNikkiSystem Project